記事番号:00299
現象
- ログインに時間がかかる
- 操作全般で時間がかかる
-
次のエラーが複数のユーザーで頻発する
エラーメッセージ:(DB01205)
DBサーバー上で、ロック獲得がタイムアウトしました。エラーメッセージ:(DB01213)
データベース上でデッドロックが発生しました。エラーメッセージ:(DB01040)
DBサーバーへの接続クライアント数が多すぎます。
原因
「Garoon」のパフォーマンスが低下してる恐れがあります。
対処
次の設定を試してください。
- 「ログイン時の新着メールチェック」を [設定しない] に設定する
- 新着メール情報ポートレットをポータルから削除する
- 「メールの自動受信」を、深夜などユーザーのアクセスが少ない時間帯に実行する
- ロゴやアプリケーションメニューのアイコンをURL形式に変更する
- 「Garoon」の利用ユーザーから削除されたユーザーのデータの削除は、
ユーザーのアクセスが少ない時間帯に実行する - 「Garoon」を運用するサーバーマシンにあるタスクやクーロンなどは、
ユーザーのアクセスが少ない時間帯に実行するように設定する - 「ロギング」データの検索や削除は、ユーザーのアクセスが少ない時間帯に実行する
- 「(全施設)の表示」を無効にする
- 画面上部のヘッダーにある、「最新情報」の取得間隔を変更する
上記の各設定の詳細は、下記に説明しています。
-
対処 A と対処 B :
新着メールのチェック時に、「Garoon」とメールサーバーが通信します。
その通信に時間がかかると、「Garoon」のパフォーマンスに影響することがあります。
・対処 A の操作:- 「システム管理」画面にアクセスする。
- [各アプリケーションの管理] > [メール] > [一般設定]の順にクリックする。
- 「ログイン時の新着メールチェック」欄で、[設定しない]を選択する。
・対処 B の操作:
- 「システム管理」画面にアクセスする。
- [各アプリケーションの管理] > [ポータル] > [ポータルの一覧]の順にクリックする。
- 使用しているポータルを選択する。
- ポータルの詳細画面の「ポートレット一覧」から新着メール情報ポートレットを削除する。
-
対処 C :
ユーザーのアクセスが少ない時間帯にメールを受信すると、
アクセスが集中する始業時などでシステムの負荷を軽減できます。
・対処 C の操作:- 「システム管理」画面にアクセスする。
- [各アプリケーションの管理] > [メール] > [一般設定] の順にクリックする。
- メールの自動受信の時間を変更する。
注意
- メールの自動受信中は、システムに高い負荷がかかります。
メールの自動受信を設定する場合は、業務に支障のない時間を指定してください。
-
対処 D :
ロゴやアプリケーションメニューのアイコンをファイル形式で指定すると、
ユーザーのアクセスする度にファイルを取得するためのリクエストが行われるため、
「Garoon」への同時アクセス数が増加します。
ロゴやアプリケーションメニューのアイコンを設定する場合は、
HTTP経由でアクセスできるサーバーマシンのディレクトリーに画像ファイルを保存し、
その画像の保存先の URL を指定します。
・対処 D の操作:
- ロゴのアイコン- 「システム管理」画面にアクセスする。
- [基本システムの管理] > [お客様情報] > [お客様情報の確認]の順にクリックする。
- ロゴのアイコンをURLで指定する。
- アプリケーションメニューのアイコン
- 「システム管理」画面にアクセスする。
- [基本システムの管理] > [画面] > [アプリケーションメニュー一覧]の順にクリックする。
- 各アプリケーションメニューのアイコンを URL で指定する。
-
対処 E :
「Garoon」の利用ユーザーから削除されたユーザーのデータを削除すると、
一時的にシステムに高負荷がかかることがあります。ユーザーのデータを削除する場合は、
ユーザーのアクセスが少ない時間帯に実行してください。
-
対処 F :
「Garoon」を運用するサーバーマシンにあるタスクやクーロンを実行すると、
一時的にシステムに高負荷がかかる場合があります。負荷がかかるタスクやクーロンの実行は、
ユーザーのアクセスが少ない時間帯に実行してください。
-
対処 G :
「ロギング」データが大量に蓄積されている状態で、次の操作をすると
一時的にシステムに高負荷がかかることがあります。
・ログ一覧にアクセスする
・ログを検索する
・ログをファイルに書き出す
・ログを一括で削除する
次の点に注意して、「Garoon」を運用してください。
・負荷がかかる操作をユーザーのアクセスが少ない時間帯に実行する
・ログを定期的に削除する
-
対処 H :
「(全施設)の表示」を無効にすると、スケジュールの一覧画面を表示する
動作の負荷を軽減できます。
・対処 H の操作:- 「システム管理」画面にアクセスする。
- [各アプリケーションの管理] > [スケジュール] > [一般設定] の順にクリックする。
- [(全施設)の表示] を無効にする。
-
対処 I :
「Garoon」は、5分間隔で自動的に取得した最新の通知を、画面上部の
ヘッダーにある「最新情報」に表示します。サーバーマシンの負荷状況に合わせて
「最新情報」を取得する間隔を変更することで、現象の改善が見込めます。
変更手順の詳細は、次の FAQ を参照してください。
FAQ:画面のヘッダーに表示される「最新情報」は、何分間隔で更新されますか?
固定リンクをコピーします
固定リンクがコピーされました